cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
09. Dezember 2021 um 10:32

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Hilfe für webFrame  CGI »


   cgicorner.ch
   Hilfe
   CGI/Perl allgemein

   Hilfe für webFrame  CGI
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Hilfe für webFrame  CGI  (Gelesen 2020 mal)
jurassic
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Geschlecht: male
Beiträge: 9
Hilfe für webFrame  CGI
« am: 23. März 2006 um 15:08 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo
 
Ich habe eine Version von webFrame dowgeloaded welche ich auf meiner Homepage nicht lauffähig kriege. Hier die Downloadadresse  http://www.web-scribble.com/products/webframe/index.shtml
 
Da ich ein absoluter Neuling bin wollte ich anfragen wer mir dabei helfen kann dieses skript lauffähig zu machen.
 
danke und grüsse
Jurassic
 
 
Hallo nochmals  
 
Um mich zum ersten Beitrag korrekter auszudrücken. Ich habe die skrips lauffähig auf dem Server und sehe die Seiten auch auf meiner Homepage, bekomme jedoch einige Funktionalitäten nicht hin und weiss nicht was wo und wie anzupassen ist.  
 
danke und gruss nochmals  
Jurassic
« Zuletzt bearbeitet: 23. März 2006 um 21:30 von cgicorner.ch » gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Hilfe für webFrame  CGI
« Antworten #1 am: 23. März 2006 um 21:41 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jurassic
 
Zuallererst: ich kenne das Script nicht und kann deshalb auch keinen genauen Support leisten. Ich habe es aber schnell heruntergeladen und anschaut: das Script ist ziemlich primitiv, sowohl in Bezug auf Nutzung als auch Funktionalität.
 
 
Die Installation ist in der install.html erklärt und eigentlich mit der Anpassung der Variable: $title und $cgipath in der webframe.pl und $adminpassword in der webframeadmin.pl erledigt. Danach müssen nur noch die chmod-Rechte vergeben werden. Da du schreibst, dass das Script läuft gehe ich davon aus, dass dies geklappt hat.
 
Danach wird das Script mit webframe.pl?http://www.meinserver.ch/seite.htm aufgerufen. Das Script macht nichts anderes als ein Frameset zu generieren: oben wird die top.html angezeigt, untern die Seite nach dem ? in der URL. Das Layout des oberen Balken steuerst du in der top.html, wenn das Frame höher sein soll änderst du die webframe.pl ab (rows="28,*"). Mit webframeadmin.pl hast du den Adminbereich, wo du siehst, welches die Einstiegsurls sind.
 
Mittels SSI
<!--#include virtual="cgi-bin/webframe.pl?top10" -->
oder einfach als URL
/cgi-bin/webframe.pl?top10
kannst du die 10 beliebtesten Einstiegsseiten anschauen. Dann ist die Funktionalität des Scriptes voll ausgeschöpft.
 
Ich persönlich sehe hinter dem Script ehrlich gesagt nur sehr wenig Sinn. Funktionieren tut es ja sofort, aber Nutzen hast du sehr wenig...
 
Ich hoffe, dies hilft dir weiter.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
jurassic
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Geschlecht: male
Beiträge: 9
Re: Hilfe für webFrame  CGI
« Antworten #2 am: 24. März 2006 um 00:01 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Vielen Dank für die Antwort. Wie und wo kann ich die url registrieren, die ich als Content im Frame sehen möchte?
 
Im webframeadmin.pl finde ich eine zeile $content = "Action disabled for demo version."
Kann das die Ursache sein, dass ich keine ziel urls eingeben kann ?
 
herzl.Gruss
Jurassic
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Hilfe für webFrame  CGI
« Antworten #3 am: 24. März 2006 um 11:48 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jurassic
 
Keine Ahnung. Ich musste die URLs nicht registrieren, sondern konnte sie einfach angeben (Komplett inkl. http://). Einmal verwendet tauchen sie dann auch in der Statistik auf.
 
Die Meldung "disabled in demo-version" hat ja ein # davor und ist damit reiner Kommentar. Zudem ist diese Meldung rein informativer Text (wird in webframetemplate.html anstatt |CONTENT| dargestellt).
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.