cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
28. November 2021 um 08:48

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « sendmail konnte nicht geöffnet werden »


   cgicorner.ch
   Hilfe
   CGI/Perl allgemein

   sendmail konnte nicht geöffnet werden
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: sendmail konnte nicht geöffnet werden  (Gelesen 1565 mal)
bjoern
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Beiträge: 2
sendmail konnte nicht geöffnet werden
« am: 12. August 2006 um 17:27 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo,
 
habe den Formmailer installiert und bekomme immer die Fehlermeldung "Sendmail konnte nicht geöffnet werden at formmailer.cgi line 549."
 
Die Info ist ja mal recht konkret, ich habe aber null Ahnung von Perl und CGI und so weiß ich nicht, was in der Zeile nicht stimmt.
 
Der Pfad zu sendmail müsste nach Information meines Providers korrekt sein. Bei meinem alten Provider habe ich das Script ohne Schwierigkeiten zum Laufen gebracht... hm.
 
Danke für Hilfe!
Gruß,
Björn
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: sendmail konnte nicht geöffnet werden
« Antworten #1 am: 12. August 2006 um 18:27 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Björn
 
Die Meldung ist eigentlich ziemlich konkret und deutet schon auf Probleme mit sendmail hin. Den Pfad hast du ja gemäss deinen Angaben bereits mit deinem Hoster abgeklärt, das wäre mein Hauptverdacht gewesen...
 
Um alle anderen Probleme ausser sendmail auszuschliessen würde ich mal $mailVersand von TRUE auf FALSE setzen (im oberen Teil des Scriptes). Dies führt dazu, dass Mails nicht mehr versendet werden, sondern eine EML-Datei im Scriptverzeichnis erstellt wird: diese kannst du mit FTP herunterladen und mit Doppelklick in deinem Mailprogramm öffnen: prüfe dort, ob das Mail korrekt aussieht, insbesondere ob Absender und Empfänger stimmen.
 
Wenn dies der Fall ist, kannst du mal versuchen, auf der besagten Zeile das "-oi" zu entfernen, möglich, dass die Sendmail-Konfiguration deines Providers den Parameter nicht kennt (müsste er aber eigentlich).
 
Letzte Möglichkeit wäre noch, dass du die Mail-Templates mit UNIX-Zeilenumbrüchen speichern musst. In der Regel führt dieses Problem aber dazu, dass die Mails einfach nie ankommen und nicht, dass ein Fehler generiert wird. Ist also unwahrscheinlich, aber nicht 100%ig ausgeschlossen.
 
Wenn alles nichts hilft, melde dich nochmals hier im Forum. Dann gebe ich dir mal ein kleines Demo-Script, welches ein Mail versenden sollte aber sonst nichts macht. So können wir das Problem mal auf ein 15 Zeilen Script einschränken...
 
Ich hoffe, dies hilft dir weitetr.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
bjoern
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Beiträge: 2
Re: sendmail konnte nicht geöffnet werden
« Antworten #2 am: 12. August 2006 um 18:59 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg,
 
vielen Dank für Deine prompte Hilfe! Habe den Pfad auf Deinen ersten Verdacht hin nochmals geändert und siehe da: mein neuer Provider gab mir offenbar eine Fehlinformation. Jetzt klappt's.
 
Ich dachte zwar, diese Möglichkeit hätte ich bereits ausgeschlossen, aber da habe ich mich wohl geirrt.
 
Vielen Dank auch für das tolle Skript an dieser Stelle! Ich habe keinen Spendenbutton auf Deiner Homepage gefunden, sonst hätte ich mich da mal betätigt Wink Habe ich den übersehen?
 
Ein schönes Wochenende!
Gruß,
Björn
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: sendmail konnte nicht geöffnet werden
« Antworten #3 am: 12. August 2006 um 20:17 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Björn
 
Wunderbar, wenn's nun klappt: man merkt einmal mehr, dass die Konfiguration von CGI-Scripts nicht immer ganz einfach ist, wenn einem sogar von Providern falsche Angaben gegeben werden.
 
Ach ja: den Spenden-Button gäbe es übrigens [1]. Unterstützungen sind freiweillig, freuen ich natürlich aber immer.
 
Gruss und schönes Wochenende
Jürg
 
[1] http://www.cgicorner.ch/download/info.shtml
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.