cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
09. August 2020 um 02:06

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Formmailer einrichten »


   cgicorner.ch
   Hilfe
   CGI/Perl allgemein

   Formmailer einrichten
« Vorheriges Thema | Nächstes Thema »
Seiten: 1 2  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Formmailer einrichten  (Gelesen 28062 mal)
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Formmailer einrichten
« am: 31. Dezember 2008 um 16:20 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo,
bin neu auf diesem Forum und versuche, den Formmailer auf meinen Websites einzurichten um SPAM'er zu verbannen. Habe zwei Websites, eine bei einem ISP und die andere auf meinem privaten SUSE LINUX 11 Server.
Ich habe versucht, erst mal die Sache beim ISP (Genotec) zu installieren und zu testen. Zu diesem Zweck habe ich ein Directory "cgi_bin" mit Unterdir "formmailer" erstellt. Danach habe ich die 2 Files formmailer.cgi, seccode.jpg geladen und ein leeres config.pl File erstellt. Die Berechtigungen habe ich gemäss Anweisung auf 755 bzw. 644 eingestellt.
Nun zu meinem Problem:
- wenn ich den script formmailer.cgi?action=admin aus dem Browser aufrufe, erhalte ich die Fehlermeldung:
"Template nicht gefunden
Bei der Verarbeitung ist ein Fehler aufgetreten: es wurde kein Mail-Template definiert oder das Template konnte nicht gefunden werden. . ."
 
Welche Files fehlen? Ich dachte, dass mit dem "Admin Mode" die Templates erstellt werden. Was mache ich falsch?  
 
En guete Rutsch in ein erfolgreiches und gesundes 2009 wünscht
Hans Z.
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #1 am: 31. Dezember 2008 um 16:42 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hazet
 
Die Webseite bei Genotec läuft glaube ich auf einem Windows-Server, oder? Beim IIS habe ich schon einmal komisches verhalten festgestellt, dass das aktuelle-Verzeichis nicht das Scriptverzeichnis ist (wie man es erwarten könnte), sondern das CGI-BIN Verzeichnis oder gar der Document-Root.
 
Somit ist "./config.pl" also nicht im Scriptverzeichnis.
 
Versuch mal folgendes:
- erstelle eine config.pl im cgi-bin Ordner (nicht formmailer!)
- wird der Adminbereich angezeigt? Falls ja: config.pl wieder löschen und in der formmailer.cgi bei my $configFile="config.pl"; ein my $configFile="formmailer/config.pl"; eintragen. Funktioniert es dann? Falls nicht:
- erstelle eine config.pl im Haupt-Ordner (nicht cgi-bin oder formmailer!)
- wird der Adminbereich angezeigt? Falls ja: config.pl wieder löschen und in der formmailer.cgi bei my $configFile="config.pl"; ein my $configFile="cgi-bin/formmailer/config.pl"; eintragen. Funktioniert es dann?
 
Wenn's das ist, müsstest du sehen was alles nicht funktioniert und ggf. nochmals Bescheid geben. Die Template-Pfade müssten dann auch mit Verzeichnisangabe erfolgen, möglich, dass aber irgendetwas noch nicht funktioniert. Bevor wir aber nicht wissen, ob es wirklich die Verzeichnisse sind, macht es nicht viel Sinn, dass ich da den ganzen Code durchsuche.
 
Mit deinem privaten Linux müsste es eigentlich problemlos funktionieren. Gib mir doch Bescheid, ob es an den Pfaden lag.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #2 am: 31. Dezember 2008 um 17:15 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Danke für die umgehende Antwort.
Ich habe das config.pl file schrittweise nach oben kopiert und siehe da: Nachdem es im root directory plaziert war, bin ich im Admin mode angekommen. Doch eine Wundertüte von "billing Gates".
Für dieses Jahr mache ich jetzt Schluss.
Gruss Hans Z.  Cheesy
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #3 am: 31. Dezember 2008 um 17:18 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hans
 
Danke für die Antwort. Du kannst dir nicht vorstellen, wie lange ich das erste Mal bei jemanden gesucht habe, bis ich diese Eigenheit entdeckt habe (via E-Mail Korrespondenz schreibt man da ein paar Mails hin und her, bis man dem auf die Schliche kommt - mit Zugriff auf den Server wäre es evtl. einfacher gewesen). Das vergisst man nicht mehr so schnell... Smiley
 
Gruss und "guete Rutsch"
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #4 am: 02. Januar 2009 um 10:10 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Erst mal mein besten Wünsche für ein gutes und gesundes 2009!
 
Ich habe nun auf beiden Servern (WINDOWS bei GENOTEC und auf meinem SUSE LINUX) die cgi-bin installiert und kann bei beiden Installationen den admin mode starten.
Damit ich nicht zu viele Fehlversuche mache, wäre ich Dir für einen Vorgehenstip für diesen Fall sehr dankbar:
- Ich verwende identische Formulare in drei versch. Sprachen (d,f,e) und möchte diese wegen wiederholtem SPAM Email für die Verwendung mit Deinem Formmailer umsetzen. Wie macht man dies am rationellsten?
- wenn ich die Beschreibung richtig verstanden habe, kann dies nur im "admin"-mode gemacht werden . . .
- Das aktuelle Formular findest Du hier: http://www.bastide-immo.com/Formulare/AnfrageFormular.html
 
Besten Dank und Gruss
Hans Z.
« Zuletzt bearbeitet: 02. Januar 2009 um 10:12 von hazet » gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #5 am: 02. Januar 2009 um 14:26 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hans
 
Grundsätzlich bietet FormMailer drei Betriebsmodes:
- Templaes fix in der formmailer.cgi eingetragen (das heisst 3 Sprachen = 3 formmailer.cgi auf dem Server, nicht optimal)
- Templates mit versteckten Feldern im Formular
- Adminbereich
 
Sowohl in der Variante 2 als auch 3 mit Adminbereich kannst du mit einer FormMailer Installation drei Sprachen abdecken. Der Adminbereich ist also nicht zwingend notwendig. Vorteil des Adminbereichs ist es, dass du das Mailtemplate (und somit z.B. die Zieladresse) webbasiert anpassen kannst, sonst musst du die Datei mit FTP herunterladen, anpassen und wieder hochladen. Nachteil ist noch ein Passwort und tendenziell ist der Adminbereich eher etwas komplizierter (je nachdem, wie gewohnt man mit dem Umgang mit solchen Adminseiten ist). Die folgenden Erklärungen beziehen sich jetzt auf den Adminbereich, lassen sich aber auch relativ einfach für das andere Script verwenden.
 
Was du wissen musst ist zuerst einmal, ob das MAIL auch dreisprachig sein soll (wenn der Absender eine Kopie erhält). Falls ja, musst du natürlich drei Mailtemplates in drei Sprachen haben, falls nicht, reicht ein Mailtemplate aus und es reichen drei Formulare. Beides funktioniert, musst es nur im Voraus wissen.
 
Dann ist das Vorgehen so: erstelle mal ein Mail-Template, das so aussieht:
 
From: [email protected]
To: [email protected]
Subject: Test-Formular
 
Anrede: <!--titre-->

 
(Absender- und Zieladresse anpassen) Speichere das im selben Verzeichnis, in dem nun auch die config.pl ist (z.B. anfrage.template oder anfragedeutsch.template wenn du 3 MAIL-Templates brauchst). Gehe in den Adminbereich und erstelle ein neues Template "anfragedeutsch". Als Ziel-URL für korrekte resp. fehlerhafte Daten trägst du die URLs aus _DankePage und _FehlerPage ein. Template wäre anfrage.template oder anfragedeutsch.template, Rest lässt du leer.
 
Nun passt du die AnfrageFormular.html, löschst alle versteckten Felder im Block, der mit
 
<input type="hidden" name="_Host" value="localhost">
 
beginnt und fügst stattdessen diese Zeile ein:
 
<input type="hidden" name="id" value="anfragedeutsch">
 
Das wäre für den ersten Schritt mal alles: das Template ruft nun die ID anfragedeutsch auf: dort hast du die Ziel-URLs sowie das Mailtemplate definiert. Nun müsste das Formular funktionieren und du müsstest ein Mail bekommen, in der die gewählte Anrede ausgegeben wird. Unter Windows musst du in der formmailer.cgi wohl noch den Pfad zu sendmail anpassen, wie der genau lautet weiss ich nicht:
 
my $sendmail="/usr/sbin/sendmail";
 
Wenn du mal soweit bist und ein Mail mit einem Feld hast kannst du dich an die anderen Felder machen: einfach Name des Feldes im Template erwähnen,  
<input type="text" name="meinfeld">
ist also im Mail-Template dann
<!--meinfeld-->
 
Bei dieser Gelegenheit kannst du auch allen Pflichtfeldern noch ein NNUL_ vorne ran stellen, dein Titre wird also
<input type="text" name="NNUL_Titre">
und im Mailtemplate
<!--NNUL_Titre-->
Dann prüft FormMailer auch, ob das Feld gefüllt ist (wenn jemand Javascript deaktiviert hat).
 
Wenn dann dies alles läuft, kannst du dich optional noch an den Spam-Schutz mittels Validierungscode machen.
 
Bei den anderen Sprachen erstellst du im Adminbereich wieder eine neue ID und passt Fehler und Zielurl an. Wenn das Mailtemplate auch dreisprachig ist auch diesen Namen anpassen, sonst einfach gleich lassen. Dann kopierst du das deutsche Formular, passt das hidden-Feld "id" an und änderst die Feldbeschriftungen und speicherst es unter neuem Namen ab. Fertig.
 
Ich hoffe, das hilft dir weiter. Mein genereller Tipp: versuch zuerst ein Mail mit 1 Feld zum laufen zu kriegen, dann kennst du die Template-Pfade, Pfad zu sendmail etc. Die restlichen Felder sind dann reine Fleissarbeit, bevor aber nicht klar ist, dass alles funktioniert (und z.B. Sendmail für Windows installiert ist) wäre es dämlich, zu viel reine Fleissarbeit zu investieren und dann schlussendlich doch keinen Erfolg zu haben.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #6 am: 02. Januar 2009 um 14:58 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Ganz herzlichen Dank für Deine ausführliche Antwort. Ich habe mittlerweile ein Testformular gemacht und habe den Securecode auf dem LINUX server erfolgreich getestet. Was allerdings noch nicht su tut wie's soll, ist Mails verschicken. Ich habe sendmail auf dem LINUX Server gefunden und im frommailer.cgi den Pfad entsprechend angepasst. Was mich jedoch ein wenig "stutzig" macht, ist, dass "webinfo.cgi" unter "sendmail" einen leeren Eintrag zeigt . . .
Was ich auch noch gerne wissen möchte ist, ob's eine Möglichkeit gibt, dem Website Besucher anzugeben, welches Feld im Formular fehlerhaft war; einfach die Fehlerseite ohne weitere Angabe zum Fehler zurückzugeben ist wenig hilfreich. Ist es möglich, vor dem Aufruf des Formmailer scripts mit eigenen (bereits existierenden) Validierungsscripts (chkFormular) die Feldinhalte zu überprüfen? Der Aufruf für den Formmailer würde dann so aussehen:
<form onsubmit="return chkFormular()" action="../cgi-bin/formmailer.cgi" method="post"> <input type="hidden" name="id" value="myid">
Sollte dies möglich sein, entfielen die weiteren Validierungen im Formmailer, nicht wahr?
Im Uebrigen erwartet mich nun ja ein Menge "Fleissarbeit", aber wenn damit die ärgerlichen SPAM unterbunden werden können, tamps mieux.
Gruss Hans Z. Smiley
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #7 am: 02. Januar 2009 um 15:48 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hans
 
Pfad zu sendmail: ist meistens /usr/sbin/sendmail, manchmal noch /usr/lib/sendmail. Webinfo kann den Pfad leider nicht in allen Fällen zuverlässig erkennen (wäre dies der Fall würde ich den Pfad ja autmatisch ermitteln). Auf der Shell müsste "which sendmail" eigentlich den korrekten Pfad zurückliefern.
 
Fehler-Details: die Einbindung von Java-Script ist weiterhin möglich. Ebenfalls kann FormMailer das Formular selber wieder als Template verarbeiten und dann genauere Fehlermeldungen ausgeben. Das setzt dann aber voraus, dass du das Formular selber nicht als HTML-Datei hast, sondern speziell einbindest. Da habe ich in der neusten Beta von FormMailer auch noch einige Verbesserungen gemacht. Bei Bedarf sende ich dir gerne die neuste BETA-Version mit einem kleinen Beispiel.
 
Auch wenn du bei der Java-Script Variante bleibst, würde ich zusätzlich mit den NNUL_Tags von FormMailern arbeiten. Dann hast du es so, dass alle User mit aktiviertem Java-Script Detail-Fehlermeldungen deiner JavaScript-Funktion bekommen, alle mit deaktiviertem Javascript (und Spam-Roboter) die Fehlerseite von FormMailer. Arbeitest du ohne FormMailer-Tags können User mit deaktiviertem JavaScript (oder eben auch Spam-Roboter) auch unvollständige Formulare erfolgreich absenden - das ist wohl kaum erwünscht.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #8 am: 02. Januar 2009 um 16:35 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Ich habe mal auf dem LUNIX töff nachgeschaut und festgestellt, dass SENDMAIL sowohl in /usr/sbin als auch in /usr/lib vorhanden ist. Trotzdem findet immer noch kein Mail xfer statt obwohl die OK Seite angezeigt wird. Ich bin kein UNIX Spezi! Meine diesbezüglichen Kenntnisse beschränken sich auf die Installation von LINUX, APACHE, SAMBA und Netzwerk . . . muss da eventuell noch irgendwo an einem Config file geschraubt werden damit sendmail weiss, wie/wohin er die Emails absetzen kann/muss? Oder brauchts neben SENDMAIL noch andere Module? Ich habe im hosts file einen entsprechenden Eintrag für SMTP.bastide-immo.com gemacht. Mein Mailserver für bastide-immo.com ist im gleichen lokalen Netz wie der HTTP server (zwei versch. PC's). Huh
 
Gruss Hans Z.
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #9 am: 02. Januar 2009 um 17:52 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hans
 
Versuch mal in der formmailer.cgi den Wert von $mailVersand auf "FALSE" zu ändern. Dann wird das Mail nicht versendet, sondern als EML-Datei im Scriptverzeichnis gespeichert.
 
Wird die EML-Datei erstellt? Hat sie auch einen Inhalt? Stimmt From und To? Hat es eine Leerzeile zwischen Header (From, To, Subject) und dem eigentlichen Inhalt?
 
Wenn da alles gut aussieht, müsstest du mal sehen, was die Logfiles aussagen, du findest diese wahrscheinlich unter /var/log/maillog. Konfigurationen sind eigentlich keine notwendig, einige Provider lehnen aber Mails ab, wenn der Hostname keine Domain enthält (also z.B. "linux" statt "linux.home.local" heisst), keine gültige Domain hat oder was auch immer.
 
Wenn das Template leer ist, nicht erstellt wird oder sonst Fehler aufweist, müsstest du da ggf. Anpassungen vornehmen.
 
Ein
ls | mail [email protected]
auf der Shell sendet übrigens einen ls per E-Mail an die angegebene Adresse: so lange dies nicht ankommt ist deine Linux-Kiste noch nicht sauber konfiguriert.
 
Ich hoffe, das hilft dir weiter.
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #10 am: 02. Januar 2009 um 18:40 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Beide funktionieren. Es wird ein .eml file geschrieben und das Mail command reagiert ohne Fehlermeldung. Jetzt muss ich wohl hinter die LINUX KISTE und die Nadel im Heuhaufen suchen . . .
Schönen Abend und Gruss
Hans Z.
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #11 am: 02. Januar 2009 um 19:42 »
Zitieren Zitieren Bearbeiten Bearbeiten

Na ja, dann viel Erfolg. Wenn das EML geschrieben wird, heisst dies mal, dass grundsätzlich das Template gelesen werden kann.
 
Wie gesagt: ich würde mal einen Blick ins Log werfen: /var/log/maillog
 
sendmail hat den Vorteil, dass es immerhin relativ "geschwätzig" ist, d.h. in den Logs in der Regel Fehlermeldungen vorhanden sind...
 
Gruss und ebenfalls einen schönen Abend
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #12 am: 05. Januar 2009 um 10:22 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg
Auf der LINUX Kiste habe ich übers Wochenende versch. Aktionen durchgeführt :
- komplette Neuinstallation
- Webserver neu aufgesetzt
- GD Module und Perl geladen
- Netz konfiguriert
- MTA mit masquerading konfiguriert
Jetzt funzt alles bis auf ein paar kleine Details (möglicherweise ein verstecktes Konfigproblem?):
Um das Problem zu schildern, muss ich noch folgende Konfigdetails zu meinem Netz angeben: hinter dem ADSL Modem/Router betreibe ich ein LAN mit 3 PC's:
  - 1 x LINUX mit dem Webserver und Drucker
  - 1 x VISTA mit Mailserver (IceWARP)
  - 1 x VISTA Notebook via WLAN
Mails an remote Server funktionieren! Wenn ich eine Email an meinen lokalen Mailserver absetze, reklamiert der Mailserver gemäss Mail.info mit der Meldung: ".... (connect to meine.domain [meine router IP-adresse]:25: connection refused)
Wie gebe ich meinem LINUX bekannt, dass der Mailserver sich in meinem lokalen Netz befindet (192.168.0.x). Funzt das gleich wie mit dem host file unter VISTA?
Danke für einen hilfreichen Tipp. Sobald ich die neuen Formulare fertig erstellt habe werde ich Mitteilung machen.
Gruss und schöne Woche
Hans Z.
 
PS. LINUX stellt wegen der Vielfalt der für die Konfiguration verfügbaren Module echt eine Herausforderung dar. Kommt hinzu, dass die zugehörige Doku meist nicht dem aktuellen Release level entspricht . . . etwas für "bit polisher"!
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer einrichten
« Antworten #13 am: 05. Januar 2009 um 20:28 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Hans
 
Ich weiss nicht, ob die Anpassung der /etc/hosts ausreicht, kannst es aber mal ausprobieren. Das ist vom Aufbau her identisch.
 
Der Mailserver ist aber ja grundsätzlich eine Abfrage des MX-Records. Wenn dieser gleich die IP zurückliefert nützt dies wenig.
 
Falls nicht, musst du den Mailer-Daemon direkt anpassen, das ist - je nachdem ob Sendmail oder Postfix läuft die /etc/mail/mailertable (Sendmail) oder /etc/postfix/transport (Postfix). Syntax und Befehl, der nach der Anpassung vorgenommen werden muss, findest du im Internet dann sicher.
 
Ich würde aber auf jeden Fall zuerst mal versuchen, die Hosts-Datei anzupassen...
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
hazet
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Geschlecht: male
Beiträge: 19
Re: Formmailer einrichten
« Antworten #14 am: 05. Januar 2009 um 20:40 »
Zitieren Zitieren Bearbeiten Bearbeiten

Guten Abend Jürg
Danke für Deine Tipps. Werde diese morgen mal asuprobieren.
habe heute Nachmittag mit meinem ISP Support Kontakt und habe erfahren, dass SENDMAIL unter WIN hosting nicht unterstützt sei. Roll Eyes
Darauf hin habe ich mich entschlossen, vom WIN auf UNIX hosting zu wechseln. Wird mir zu mühsam, mich weiter mit unterschiedlichen Hosts rum zu plagen. Wahrscheinlich wäre mit dem GD Support unter WIN Hosting auch tote Hose?
Schönen Abend und Gruss
Hans Z.
PS. Das Prototyp Formular auf dem LINUX server ist unter http://www.bastide-immo.com/Formulare/AnfrageFormular_frm.html zu besichtigen.
gespeichert

Wer Angst hat, Fehler zu machen, hat schon den ersten gemacht!
Seiten: 1 2  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.