cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
09. August 2020 um 02:18

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Formmailer - Mail ohne Werte »


   cgicorner.ch
   Hilfe
   CGI/Perl allgemein

   Formmailer - Mail ohne Werte
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Formmailer - Mail ohne Werte  (Gelesen 3310 mal)
Rimba
YaBB Newbie
*





   


Beiträge: 3
Formmailer - Mail ohne Werte
« am: 24. Mai 2010 um 15:25 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo zusammen
 
Gerne wende ich mich mit folgender Bitte / Problemstellung an Euch:
Die Formularwerte, welche mittels Formmailer ausgelesen und als
Mail verschickt werden, sind nicht im Mail enthalten.
 
Formmailer-Version: 10. Mai 2010
Konfigurationsmode: 3
 
Ebenfalls getestet:
.. method="post" enctype="multipart/form-data">
.. method="post" enctype="multipart/mixed">
 
Funktioniert:
- Adminbereich
- Templates / Feldauflistung: <!--list:.*§§.*§-->
  (auch mit <!--list:NNUL_.*§§.*§--> getestet)
- HTML-Fomular reagiert richtig bei NNUL_-Feldern
- NOK und OK URL's einwandfrei
 
Problem:
Mail wird übermittelt, Header korrekt sowie alle Werte des Templates
(IP-Nr., Datum etc.) sind enthalten, leider nur nicht die Formularwerte
(inkl. den Pflichtfelder-Werten).
 
Würde mich sehr über den "Schubs in die richtige Richtung" freuen.
Besten Dank im Voraus.
 
Gruss
Rimba
« Zuletzt bearbeitet: 24. Mai 2010 um 15:26 von Rimba » gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
Re: Formmailer - Mail ohne Werte
« Antworten #1 am: 24. Mai 2010 um 15:32 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Rimba
 
Eigenartig. Ich würde mal prüfen, dass weder das Formular noch das Template UTF8 oder gar UTF16 codiert ist.
 
Ebenfalls zur Sicherheit hier nochmals der Syntax:
Formular: <input type="text" name="meinfeld" />
Template: <!--meinfeld-->
Verwende im Feldnamen keine Umlaute und beachte, dass Gross-/Kleinschreibung eine Rolle spielt.
 
Wenn alles nichts hilft, wäre ich froh, wenn du mir das Formular und das Template mal gezippt als E-Mail senden könntest, damit ich selber einen Blick darauf werden kann. Ist wahrscheinlich keine Hexerei, wenn die Prüfung auf Pflichtfelder schon mal funktioniert, aber so auf Anhieb fällt mir auch nichts besseres mehr ein.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Rimba
YaBB Newbie
*





   


Beiträge: 3
Re: Formmailer - Mail ohne Werte
« Antworten #2 am: 24. Mai 2010 um 16:24 »
Zitieren Zitieren Bearbeiten Bearbeiten


Hallo Jürg
 
Vielen Dank für Deine schnelle Antwort!
Habe Dir eben die gezippten Dateien geschickt.
 
Besten Dank für den "Blick unter die Haube".
 
Rimba
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 787
rRe: Formmailer - Mail ohne Werte
« Antworten #3 am: 24. Mai 2010 um 17:02 »
Zitieren Zitieren Bearbeiten Bearbeiten

War UTF-8. Problem per E-Mail gelöst (zur Erkennung von UTF-8 empfiehlt sich ein von mir unter http://www.cgicorner.ch/kb/textedit/Texteditoren vorgestellter Texteditor; PsPad ist da sehr gut).
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Rimba
YaBB Newbie
*





   


Beiträge: 3
Re: Formmailer - Mail ohne Werte
« Antworten #4 am: 26. Mai 2010 um 17:57 »
Zitieren Zitieren Bearbeiten Bearbeiten

Es funktioniert - herzlichen Dank für die Hilfe und die tolle Unterstützung!
 
Beste Grüsse
Rimba
 
« Zuletzt bearbeitet: 26. Mai 2010 um 17:57 von Rimba » gespeichert
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.