cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
21. Oktober 2021 um 03:17

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Problem mit Umlauten »


   cgicorner.ch
   Hilfe
   cal

   Problem mit Umlauten
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Problem mit Umlauten  (Gelesen 9807 mal)
Kalle
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Beiträge: 2
Problem mit Umlauten
« am: 24. Juni 2009 um 09:55 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg,
 
ich habe gerade nochmal nachgesehen: Am 03.01.2005 habe ich mich hier im Forum für das tolle Script bedankt. Seit dem werkelt es brav und problemlos vor sich hin.
Bisher hatte ich das Script auf "selbstgebastelten" Seiten eingesetzt, da ich mittlerweile aber zweimal Opa geworden bin und meine Zeit nun mehr meinen Enkeln widme, bringe ich nun Joomla zum Einsatz. Spart bei der täglichen Pflege der Seite doch eine Menge Zeit. Ich habe den Kalender dort mittels Wrapper eingebunden und er funktioniert auch tadellos. Es gibt nur einen kleinen Schönheitsfehler: Die Umlaute werden nicht richtig dargestellt. Auf www.lfc-fans.de/cms kann man das sehen. Ich vermute zwar, dass das an Joomla liegt, vielleicht hast du aber trotzdem einen Tipp.
 
Vielen Dank und viele Grüße in die Schweiz!
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Problem mit Umlauten
« Antworten #1 am: 24. Juni 2009 um 17:39 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Kalle
 
Nein, das ist nicht Joomla, das liegt am Kalender. Irgendwie werden die Umlaute falsch übermittelt. Ich vermute, es liegt an der Datendatei: hast du einen bestehenden Kalender verwendet (also Datei via FTP heruntergeladen und neu hochgeladen?).
 
Grenzen wir mal den Fehler ein: lösche im data-Verzeichnis die zwei Dateien cal.cache und cal.cache1 und benenne die cal.dat und rcal.dat um (z.B. cal.da_ und rcal.da_). Rufe nun den Kalender auf: er müsste leer sein. Erfass einen neuen Termin mit Umlauten: klappt das?
 
Falls es so ist, speichere die Dateien mal neu ab, als ANSI. Wenn du nicht genau weisst, wie das geht: downloade die zwei Dateien via FTP, packe sie in ein ZIP-Archiv und mail sie mir, dann mach ich dir das kurz.
 
Funktioniert es nicht, könnte es an einer falschen codierung der cal.cgi liegen: so oder so: welche Version setzt du ein, wenn immer möglich solltest du auf die aktuellste Version 1.08 aktualisieren.
 
Ich hoffe, das hilft dir weiter. Sonst melde dich wieder bei mir und teil mir mit, ob es a) mit der leeren Datei funktioniert und b) welche Version du einsetzt (wenn du die cal.cgi herunterlädst und in einem Editor öffnest steht es zuoberst).  
 
Wenn's mit neuen Dateien funktioniert, sende mir die die cal.dat und rcal.dat gezippt, wenn's damit immer noch nicht funktioniert und du noch nicht die neuste Version einsetzt, versuch mal einen Update (wenn's nicht klappen will, sende mir die Original cal.cgi, dann sende ich dir die fertig konfigurierte aktuellste cal.cgi zurück).
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Kalle
YaBB Newbie
*



I love YaBB 1G - SP1!

   


Beiträge: 2
Re: Problem mit Umlauten
« Antworten #2 am: 28. Juni 2009 um 09:18 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Jürg,
 
vielen Dank für die schnelle und umfangreiche Hilfe. Ich habe also alles probiert, was du vorgeschlagen hast, aber ohne Erfolg. Ich habe auch die von mir genutzte 1.05 völlig neu installiert und zusätzlich auch die 1.08. Beide zeigen das gleiche Verhalten. Beim experimentieren ist mir aber folgendes aufgefallen: Rufe ich den Kalender direkt auf, dann zeigt er die Umlaute korrekt an. Ist er in Joomla eingebunden, sind sie falsch. Klicke ich aber z.B. auf "weiter", sind sie wieder richtig. Erst wenn ich wieder auf "heute" klicke, kommt der Fehler wieder.
Es scheint sich um ein Problem im Zusammenspiel mit Joomla zu handeln. Google wirft da auch Probleme mit einigen anderen eingebunden Skripten aus.
Egal, der Kalender ist so toll, dass ich nicht darauf verzichten werde. Glücklicherweise gibt es ja kaum Gegner, die Umlaute im Namen haben.
 
Viele Grüße
 
Kalle
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Problem mit Umlauten
« Antworten #3 am: 29. Juni 2009 um 18:29 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Kalle
 
Danke für dein Feedback. Es scheint tatsächlich irgendwie mit Joomla zusammenzuhängen, mit Opera ist es wie von dir beschrieben, IE stellt es auch zuerst falsch dar, weiter dann korrekt und heute zeigt es bei mir weiterhin korrekt an, unter Firefox will es gar nicht funktionieren.
 
Ich müsste etwas rumspielen, wenn du auf die Umlaute verzichten kannst super, sonst müsste ich mal schauen, dazu müsste ich aber sicher mal gezippt deine Kalender-Installation haben, super wäre sogar ein FTP-Zugang.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
webrossi
YaBB Newbie
*



Es lebe die Liebe...

   
Homepage

Geschlecht: male
Beiträge: 12
Re: Problem mit Umlauten
« Antworten #4 am: 20. Dezember 2010 um 10:15 »
Zitieren Zitieren Bearbeiten Bearbeiten

Im IE klappt es mit den Umlauten. Im Firefox bin ich etwas ratlos, weil es in der Terminüberschrift nicht klappt - aber in den Termindetails.  
Überschrift und Details unterliegen doch der gleichen Zeichenformatierung - denke ich ... und leider ist der Firfox der verbreiteste Browser. Gibt es da einen Trick?
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Problem mit Umlauten
« Antworten #5 am: 20. Dezember 2010 um 18:06 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo
 
Ich kann das Problem nicht nachvollziehen. Bei mir funktionieren Umlaute mit IE und Firefox:
http://www.cgicorner.ch/cgi-bin/demo/cal/cal.cgi
 
Rufst du das CAL-Script direkt auf oder ist es in eine Seite eingebunden? Wo tritt das Problem auf: wenn Umlaute mit Firefox erfasst werden oder wenn Umlaute mit Firefox dargestellt werden (wenn du im IE und in Firefox je einen Eintrag mit Umlauten erfasst: wie stellt der IE und Firefox dann die zwei Beiträge dar?). Hast du eine URL, unter der ich das Problem nachvollziehen kann (kannst sie mir auch per E-Mail senden, wenn du sie nicht ins Forum posten willst).
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.