cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
20. Januar 2021 um 16:45

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « jsstat - Problem bei Einrichtung »


   cgicorner.ch
   Hilfe
   jsStat

   jsstat - Problem bei Einrichtung
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: jsstat - Problem bei Einrichtung  (Gelesen 2790 mal)
AlexBeck
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Beiträge: 2
jsstat - Problem bei Einrichtung
« am: 22. August 2004 um 12:24 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Leute, hab folgendes Problem:
 
 
HTTP Error 500
HTTP Fehler 500 - Interner Serverfehler
Es ist ein Fehler aufgetreten. Wir werden die Störung baldmöglichst beheben und entschuldigen uns für die Unannehmlichkeit.
Sollte dieses Problem weiterhin auftreten, so bitten wir sie, den Administrator zu kontaktieren: [email protected]
 
Additional information:
[Sun Aug 22 12:20:50 2004] Simple.pm: Can't locate LWP/Simple.pm in @INC (@INC contains: /opt/KQperl/lib/sun4-solaris/5.00405 /opt/KQperl/lib /opt/KQperl/lib/site_perl/sun4-solaris /opt/KQperl/lib/site_perl .) at jsstat.cgi line 3699.
BEGIN failed--compilation aborted at jsstat.cgi line 3699.
 
 
Ergebnis von jsdiag lautet:
jsDiag - Fehlerdiagnose
Webserver
Perl-Version 5.00405  
Webserver Apache/1.3.26 (Unix) mod_x-httpd-php4_script  
Administrator [email protected]  
Betriebssystem Unix  
 
Client
Client Betriebssystem Microsoft Windows XP  
Browserkennung Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)  
Browser Microsoft Internet Explorer 5.5 oder höher  
Browser-Status jsStyle Produkte werden mit dem Internet Explorer getestet. Keine bekannten Probleme  
Referer für Referer-Check hier klicken  
 
jsStat
Berechtigungen jsstat.cgi Das Script hat Lese- und Ausführberechtigungen  
Zeilenumbrüche jsstat.cgi korrekte UNIX-Zeilenumbrüche  
Konfigurationsdatei Datei "config.pl" existiert
Lese- und Schreibzugriff für "Konfigurations-Datei config.pl" vorhanden
korrekte UNIX-Zeilenumbrüche  
Dateien im Script-Verz.. Verzeichnis "." existiert; Dateien können erstellt, geschrieben und gelesen werden  
Dateien im Data-Verz. Verzeichnis "data/" existiert; Dateien können erstellt, geschrieben und gelesen werden  
Dateien im Stat-Verz. Verzeichnis "stat/" existiert; Dateien können erstellt, geschrieben und gelesen werden  
Convert-Datei Datei "data/convert.txt" existiert
Lese- und Schreibzugriff für "Convert-Datei" vorhanden
korrekte UNIX-Zeilenumbrüche  
CSS neue Browser Datei "data/brow_new.css" existiert
Lese- und Schreibzugriff für "CSS neue Browser" vorhanden  
CSS alte Browser Datei "data/brow_old.css" existiert
Lese- und Schreibzugriff für "CSS alte Browser" vorhanden  
Daten-Datei Datei "data/data.txt" existiert nicht
Lese- und Schreibzugriff auf Daten-Datei vorhanden  
Komp. Statistik Datei Datei "stat/kompstat.txt" existiert nicht
Lese- und Schreibzugriff auf Kompr.-Statistik-Datei vorhanden  
Statistik Datei Datei "stat/statistik.txt" existiert nicht
Lese- und Schreibzugriff auf Statistik-Datei vorhanden  
VisitLog Datei Datei "stat/visitlog.txt" existiert nicht
Lese- und Schreibzugriff auf VisitLog-Datei vorhanden  
 
 
Bitte um Hilfe
 
Alex
 
 
 
 
 
------------------------------------------------------------------------ --------
Copyright © 2003 by Jürg Sommer, [email protected]  Version 1.10
Letzte Änderung: 25. Januar 2004  
 
 
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: jsstat - Problem bei Einrichtung
« Antworten #1 am: 22. August 2004 um 12:37 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Alex
 
Das heisst, dass dein Provider ein von jsStat benötigtes Modul (LWP:Simple) nicht installiert hat. Glücklicherweise ist dies nicht das wichtigste Modul, so dass du jsStat auch ohne betreiben kannst. Du hast nun zwei Varianten:
 
1. Installier das Modul LWP::Simple, sofern du deinen eigenen Server hast (Webhoster installieren im Normalfall keine Module auf Kundenwunsch).
 
2. Entferne die Verweise für LWP::Simple aus jsStat. Damit ist es nicht mehr möglich, das Land bei der RIPE abzufragen. Aus diesem Grund wird die Trefferquote bei der Landauflösung etwas geringer sein. Dies ist aber der einzige Nachteil. Um LWP::Simple aus dem Script zu entfernen, musst du die Datei jsstat.cgi wie folgt editieren:
 
Lösche die Zeile use LWP::Simple;
 
Ersetze
sub getPage      # Seite in Array einlesen (benötigt LWP::Simple)
 {
 my ($webpage,@HTMLfile);
 $webpage = get($_[0]);
 @HTMLfile = split(/\n/,$webpage);
 return @HTMLfile;
 }

durch
sub getPage      # Seite in Array einlesen (benötigt LWP::Simple)
 {
 return "";
 }

 
Wichtig: Diese manuellen Manipulationen müssten bei der Installation einer neuen Version von jsStat jeweils wiederholt werden!
 
Ich hoffe, diese Antwort hilft dir weiter.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
AlexBeck
YaBB Newbie
*



I love YaBB 1G - SP1!

   
Homepage

Beiträge: 2
Re: jsstat - Problem bei Einrichtung
« Antworten #2 am: 23. August 2004 um 22:03 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hat super geklappt.
 
Vielen Dank! Ihr seid halt echte Profis.
 
 Grin
gespeichert
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.