cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
21. Oktober 2021 um 03:32

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Richtiges Einbinden der Jsstat in Frameseite »


   cgicorner.ch
   Hilfe
   jsStat

   Richtiges Einbinden der Jsstat in Frameseite
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Richtiges Einbinden der Jsstat in Frameseite  (Gelesen 2188 mal)
Kurt
Gast

E-Mail

Richtiges Einbinden der Jsstat in Frameseite
« am: 12. September 2004 um 10:04 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Hallo,
 
ich hab das Jsstat in meine HP eingebunden und lauft auch wunderbar bis auf eines!!
Ich bekomme entweder keinen refere angezeigt
oder meine Seiten bleiben weiss  Undecided
 
Kann mir vielleicht einmal  
jemand sagen welchen quelltext
ich wo und wie einbinden muss um auch den referee
richtig angezeigt zu bekommen??
 
Ich Arbeite mit Postnuke und rufe die seiten
über ein frame auf.
Der Quelltext der Seite sieht so aus
Zitat:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-15">
<title>TestSeite</title>
<meta name="KEYWORDS" content="HuhHuh??">
<meta name="DESCRIPTION" content="HuhHuh??">
<meta name="ROBOTS" content="INDEX,FOLLOW">
<meta name="resource-type" content="document">
<meta http-equiv="expires" content="0">
<meta name="author" content="HuhHuh??">
<meta name="copyright" content="Copyright (c) 2003 by HuhHuh">
<meta name="revisit-after" content="1 days">
<meta name="distribution" content="Global">
<meta name="rating" content="General">
</head>
<frameset rows="100%,*" border="0">
<frame src="index.php"  frameborder="0">
<frame frameborder="0" noresize>
</frameset>
</html>

Ich steh jetzt total daneben
vielleicht kann mir ja hier jemand helfen
 
lg
Kurt
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #1 am: 12. September 2004 um 14:09 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Kurt
 
Versuch mal den folgenden Code:
Code:
<html>  
<head>  
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-15">  
<title>TestSeite</title>  
<meta name="KEYWORDS" content="??">  
<meta name="DESCRIPTION" content="??">  
<meta name="ROBOTS" content="INDEX,FOLLOW">  
<meta name="resource-type" content="document">  
<meta http-equiv="expires" content="0">  
<meta name="author" content="??">  
<meta name="copyright" content="Copyright (c) 2003 by ">  
<meta name="revisit-after" content="1 days">  
<meta name="distribution" content="Global">  
<meta name="rating" content="General">  
 
<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript">
  <!--
  var useFlash = navigator.mimeTypes &&
  navigator.mimeTypes["application/x-shockwave-flash"] &&
  navigator.mimeTypes["application/x-shockwave-flash"].enabledPlugin;
  //-->
</SCRIPT>
<SCRIPT LANGUAGE="VBScript" TYPE="text/vbscript">
  <!--
  On error resume next
  useFlash = NOT IsNull(CreateObject("ShockwaveFlash.ShockwaveFlash"))
  //-->
</SCRIPT>
<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript">
  <!--
  if(useFlash) flash=true;
  else flash=false;
  a="na";
  f="na";
  j="na";
  r="_"+escape(document.referrer)
  a=screen.width;
  b=navigator.appName
  if (b != "Netscape") {f=screen.colorDepth} else {f=screen.pixelDepth}
  j=navigator.javaEnabled()
  NS2Ch=0
  if (navigator.appName == "Netscape" && navigator.appVersion.charAt(0) == "2") {NS2Ch=1}
  if (NS2Ch == 0)
    { r="Aufloes=" + a + "&Farbtie=" + f + "&Referer=" + r + "&JavaAkt=" + j + "&JavaScr=true&FlashAk=" + flash; }
  function load()
    { frames.jsStatFrame.location.href="/cgi-bin/jsstat/jsstat.cgi?action=stat &" + r; }
  //-->
</SCRIPT>
 
 
</head>  
<frameset rows="100%,*" border="0" onLoad="load()">  
<frame src="index.php"  frameborder="0">  
<frame NAME="jsStatFrame" src="about:blank" frameborder="0" noresize>  
</frameset>  
</html>

 
Die URL zum Script muss ggf. angepasst werden.
 
Gib doch Bescheid, ob's funktioniert.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
kurt
Gast

E-Mail

Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #2 am: 12. September 2004 um 14:23 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Hallo Jürg,
 
erst mal danke für die rasche Antwort.
Leider funktioniert das nicht.
Der Refere lasst sich noch immer nicht auslesen.
 Undecided
 
Lg
Kurt
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
.Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #3 am: 12. September 2004 um 14:34 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Kurt
 
Um es etwas einfacher zu machen: sprechen wir von der Seite salzburgchat.com?
 
Falls ja (und davon gehe ich jetzt mal aus): ich habe es soeben kurz ausprobiert: Auf dieser Seite zählt nicht die jsStat auf der Hauptseite, sondern ein VisitLog mit dem Eintrag "Startseite Registrierte Benutzer".
 
Das Problem liegt darin, dass es technisch nicht steuerbar ist, welches Bild zuerst geladen wird. Hast du also ein VisitLog auf der ersten Seite, welche unmittelbar nach dem Aufruf geladen wird, ist es gut möglich, dass dieses GIF vor dem der jsStat geladen wird.
 
Abhilfen dafür gibt es zwei:
1) Entferne das VisitLog für "Startseite Registrierte Benutzer", so dass nur die jsStat zählt (VisitLogs sollten erst nach dem ersten Klick eines Benutzers eingebaut werden).
 
2) deaktiviere im Adminbereich den Eintrag "VisitLog emuliert jsStat". Dies ist NICHT empfohlen, da dann nur noch Benutzer gezählt werden, welche direkt über die Hauptseite kommen. Im Zeitalter der Suchmaschinen ist dies ein verschwindend kleiner Teil (bei mir nur ca. 10%).
 
Ich hoffe, dies hilft dir weiter.
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
kurt
Gast

E-Mail

Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #4 am: 12. September 2004 um 14:46 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Hallo Jürg,
 
ja es ist salzburgchat.com
Hab jetzt sowohl das Visitlog raus als auch das
emuliert und beides zieht nicht  Undecided
Der Referer wird leider nach wie vor nicht angezeigt
Hast du noch ne andere Idee vielleicht??
Danke nochmal für deine rasche Hilfe.
 
lg
Kurt
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #5 am: 12. September 2004 um 14:59 »
Zitieren Zitieren Bearbeiten Bearbeiten

Schei** Forum. Ist immer wieder das gleiche...
 
Bei der Zeile  
frames.jsStatFrame.location.href="/cgi-bin/jsstat/jsstat.cgi?action=stat &" + r; }
 
darf es zwischen "stat" und dem "&" kein Leerzeichen haben.
 
Pass das doch mal an und probier's nochmals. Hoffe/denke jetzt haben wir den Übeltäter...
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
kurt
Gast

E-Mail

Re: Richtiges Einbinden der Jsstat in Frameseite
« Antworten #6 am: 12. September 2004 um 15:06 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Hallo Jürg,
 
vieeeeeeeeeelen herzlichen dank!!!!!
Es funktioniert jetzt.
Mal sehen vielleicht kann ich das Visitlog jetzt doch
noch auch einbaun  Grin
Danke Danke Danke nochmal
 
SUUUUUPER SUPPORT und EXTRA SCHNELL
 
Liebe Grüsse aus Salzburg
Kurt
gespeichert
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.