cgicorner.ch

Informationen rund um Perl/CGI

Sie sind hier: Home > Forum
Yet Another Bulletin Board

Willkommen, Gast. Bitte Einloggen oder Registrieren.
20. Januar 2021 um 16:13

Übersicht Übersicht Hilfe Hilfe Suche Suche Mitglieder Mitglieder Einloggen Einloggen Registrieren Registrieren
cgicorner.ch « Fehler 404 jsstat »


   cgicorner.ch
   Hilfe
   jsStat

   Fehler 404 jsstat
« Vorheriges Thema | Nächstes Thema »
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken
   Autor  Thema: Fehler 404 jsstat  (Gelesen 2923 mal)
Uwe Jacobsen
Gast

E-Mail

Fehler 404 jsstat
« am: 24. Februar 2005 um 02:00 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Huhu Ihr,
ich mal wieder....   *schnief
Nach dem Komprimieren der Statistik läuft bei mir garnichts mehr.
Nach endlosen Probieren bekomm ich nun:
das dreisprachige HTTP Fehler 404 - Datei nicht gefunden
was fehlt ihm daHuh
Vielleicht bin ich ja mit der Zeit blind geworden, aber ich find da absolut nix, habe ja auch zwei Versione, die parallel laufen und beide sind identisch
 
Gruß uwe
gespeichert
Uwe Jacobsen
Gast

E-Mail

Re: Fehler 404 jsstat
« Antworten #1 am: 24. Februar 2005 um 13:07 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Huhu Ihr,
 
ich antworte mal gleich selber drauf...
 
versteh das Ganze zwar nicht, aber es läuft wieder
Bei der 1.Version (läuft für eine Freundin, die kein cgi hat), die funktioniert, hab ich die config.pl auf chmod 700 und den Rest alles auf chmod 755 - läuft, funktioniert...
die zweite Version (natürlich die, die für meine Seiten läuft...) lief dann nach dem Komprimieren nicht mehr, dann hab ich gefummelt und gelöscht, neu installiert und alles gleich der ersten, funktionierenden Version eingestellt, jedoch immer wieder Internal 500. Bei dieser Version hab ich nun das data-Verzeichnis auf 777, die config.pl auf 700 und den Rest auf 755. Läuft nun auch wieder.... *ggg
 
In der Version, die ich dann in einem neuem Verzeichnis habe, die mit dem Fehler 404, hab ich das stat-Verzeichnis auf 777 und den Rest inkl. config.pl auf 755. Das läuft nun auch (brauch ich zwar nicht, lass ich aber erstmal...*grins).
 
Eine Frage bleibt trotzdem, auch wenn alles läuft: jsdiag sagt, alles ist okay, warum dann Fehler 404?
 
Gruß Uwe
gespeichert
cgicorner.ch
YaBB Administrator
*****




Board Admin

   
Homepage E-Mail

Geschlecht: male
Beiträge: 790
Re: Fehler 404 jsstat
« Antworten #2 am: 24. Februar 2005 um 17:44 »
Zitieren Zitieren Bearbeiten Bearbeiten

Hallo Uwe
 
Ohne dein zweites Posting hätte ich gesagt; ganz einfach, du rufst jsstat ohne action-Argument auf.
 
/cgi-bin/jsstat/jsstat.cgi wird einen 404er Error bringen
/cgi-bin/jsstat/jsstat.cgi?action=admin wird dir den Login-Prompt liefern.
 
(ich weiss, 404 ist etwas unglücklich gewählt, wenn er vom Script aus, also dreisprachig kommt, heisst, dass unter der entsprechenden Action nichts gefunden wurde).
 
Anders sieht es aus, wenn der 404er Error nebst dem restlichen Quelltext des Scriptes angezeigt wird, dann wird das Script serverseitig gar nictt geparst.
 
Dein zweites Posting verunsichert mich allerdings ein wenig: ich wüsste nicht, das diese 404er Meldung mit Berechtigungen zu tun hat (dass du bei fehlerhaften Berechtigungen einen Internal Server Error erhälst ist klar). So ganz durchschauen tue ich dein Problem also nicht.
 
Tendenziell tippe ich aber genau auf diesen fehlenden Parameter, wenn jsDiag keine Probleme meldet und du einen dreisprachigen 404er erhälst.
 
Vielleicht reiner Zufall, dass du während deinen Tests immer mal wieder die action vergessen hast?
 
Gruss
Jürg
gespeichert

cgicorner.ch - Informationen rund um Perl/CGI
Jürg Sommer
Uwe Jacobsen
Gast

E-Mail

Re: Fehler 404 jsstat
« Antworten #3 am: 25. Februar 2005 um 11:45 »
Zitieren Zitieren Bearbeiten Bearbeiten Löschen Löschen

Huhu Ihr,
 
mir graust der Gedanke, das ich den ganzen Tag hier sinnlos geklickt habe, weil ich einen unvollständigen Link benutzt habe....
 
In der Tat fand ich im Verlauf einen Link ohne action-Angabe. Möglich, das ich auch diesen immer wieder benutzt habe...*schäm
Am nächsten Tag hab ich dann wie gewohnt in den Favoriten angeklickt und da geht es "plötzlich"
Fakt ist aber, das ich für die unterschiedlichen Versionen bei mir auch jeweils andere Rechte benötige, da sonst der Fehler 500 auftritt.
 
Im Script werd ich den 404-Hinweis mal erweitern, so in der Art wie beim Fehlerhaften Login *gg
etwa so:  
Na Herr Jacobsen, wollen wir nun endlich mal eine action angeben   *kicher
 
Dank und Gruß
Uwe
gespeichert
Seiten: 1  Antworten Antworten Bei Antworten benachrichtigen Bei Antworten benachrichtigen Drucken Drucken

« Vorheriges Thema | Nächstes Thema »

cgicorner.ch » Powered by YaBB 1 Gold - SP3!
YaBB © 2000-2004. All Rights Reserved.